{
  "draft": "draft-ietf-calext-ical-tasks-17",
  "doc_id": "RFC10051",
  "title": "Task Extensions to iCalendar",
  "authors": [
    "A. Apthorp",
    "M. Douglass"
  ],
  "format": [
    "XML",
    "TEXT",
    "HTML",
    "PDF"
  ],
  "page_count": "32",
  "pub_status": "PROPOSED STANDARD",
  "status": "PROPOSED STANDARD",
  "source": "Calendaring Extensions",
  "abstract": "The \"VTODO\" calendar component in the Internet Calendaring and Scheduling Core Object Specification (iCalendar; RFC 5545) has seen limited adoption and use, mainly for personal reminders and to-do lists.\n\nThis document updates RFC 5545 and defines extensions to \"VTODO\" to provide improved status tracking, scheduling, and specification of tasks to allow its use in other contexts, such as process control and project management.\n\nIt also defines how Calendaring Extensions to WebDAV (CalDAV) (RFC 4791) servers can be extended to support certain automated task management behaviors.",
  "pub_date": "October 2026",
  "keywords": [
    "iCalendar",
    "VTODO",
    "tasks",
    "task management",
    "task scheduling",
    "task assignment",
    "task status",
    "task dependencies",
    "CalDAV",
    "iTIP"
  ],
  "obsoletes": [],
  "obsoleted_by": [],
  "updates": [
    "RFC5545"
  ],
  "updated_by": [],
  "see_also": [],
  "doi": "10.17487/RFC10051",
  "errata_url": null
}