<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE rfc [
 <!ENTITY nbsp    "&#160;">
 <!ENTITY zwsp   "&#8203;">
 <!ENTITY nbhy   "&#8209;">
 <!ENTITY wj     "&#8288;">
]> 

<rfc xmlns:xi="http://www.w3.org/2001/XInclude" docName="draft-ietf-calext-ical-tasks-17" number="10051" category="std" ipr="trust200902" consensus="true" updates="5545" obsoletes="" symRefs="true" sortRefs="true" tocInclude="true" submissionType="IETF" xml:lang="en" version="3" >

  <front>
    <title>Task Extensions to iCalendar</title>
    <seriesInfo name="RFC" value="10051"/>

    <author fullname="Adrian Apthorp" surname="Apthorp" initials="A.">
      <organization>DHL Express</organization>
      <address>
        <postal>
          <street>Fritz-Erler-Str. 5</street>
          <city>Bonn</city>
          <country>Germany</country>
        </postal>
        <email>adrian.apthorp@dhl.com</email>
      </address>
    </author>
    <author fullname="Michael Douglass" surname="Douglass" initials="M.">
      <organization>Bedework Commercial Services</organization>
      <address>
        <postal>
          <street>226 3rd Street</street>
          <city>Troy</city>
          <region>NY</region>
          <country>United States of America</country>
        </postal>
        <email>mdouglass@bedework.com</email>
      </address>
    </author>
    <date year="2026" month="October"/>

    <area>ART</area>
    <workgroup>calext</workgroup>

    <abstract><t>The "VTODO" calendar component in the Internet Calendaring and Scheduling Core Object Specification (iCalendar; RFC 5545) has seen limited adoption and use, mainly for personal reminders and to-do lists.</t>

<t>This document updates RFC 5545 and defines extensions to "VTODO" to provide improved status tracking, scheduling, and specification of tasks to allow its use in other contexts, such as process control and project management.</t>

<t>It also defines how Calendaring Extensions to WebDAV (CalDAV) (RFC 4791) servers can be extended to support certain automated task management behaviors.</t>
</abstract>
  </front>
  <middle>
    <section><name>Introduction</name>

<t>This document specifies extensions to the Internet Calendaring and Scheduling Core Object Specification (iCalendar) <xref target="RFC5545"/> and associated protocols in order to enhance the structured communication and execution of tasks. The enhancements allow for the communication, time planning, and scheduling of tasks by and between automated systems (e.g., taxi dispatch systems, smart power grids <xref target="WsCalendar"/>, and business process management systems), as well as for human-centered tasks.</t>

<t>A "task" is a representation of an item of work assigned to an individual or organization. In the iCalendar Object Model <xref target="RFC5545"/> the representation of tasks is by "VTODO" calendar components. Tasks can be identified in a number of situations, either informally as ad hoc tasks in personal to-do lists or more formally in business processes (ranging from repetitive workflows to adaptive cases and trouble ticketing) and project management (whether for large-scale construction projects or collaborative software development).</t>

<t>The extensions specified in this document enhance and standardize the following:</t>

<ul>
  <li>The specification of tasks: How a task type is defined and the relationships between tasks; see <xref target="task-specification"/>.</li>
  <li>Task planning and scheduling: Improved specification of deadlines and estimated time for completion; see <xref target="deadlines"/>.</li>
  <li>Task assignment and status reporting: The addition of "VSTATUS" (<xref target="modifications-to-calendar-components"/>) allows for more detailed reports; see <xref target="status-reporting"/>.</li>
</ul>

<t>These extensions are defined within the context of an overall architecture for task calendaring and scheduling, which elaborates that supported by <xref target="RFC5545"/> and related standards.</t>

<section anchor="conventions"><name>Terms and Definitions</name>

<t>
    The key words "<bcp14>MUST</bcp14>", "<bcp14>MUST NOT</bcp14>", "<bcp14>REQUIRED</bcp14>", "<bcp14>SHALL</bcp14>", "<bcp14>SHALL
    NOT</bcp14>", "<bcp14>SHOULD</bcp14>", "<bcp14>SHOULD NOT</bcp14>", "<bcp14>RECOMMENDED</bcp14>", "<bcp14>NOT RECOMMENDED</bcp14>",
    "<bcp14>MAY</bcp14>", and "<bcp14>OPTIONAL</bcp14>" in this document are to be interpreted as
    described in BCP&nbsp;14 <xref target="RFC2119"/> <xref target="RFC8174"/> 
    when, and only when, they appear in all capitals, as shown here.
        </t>

<t>The notation used in this memo to (re-)define iCalendar elements is ABNF <xref target="RFC5234"/>, as used by <xref target="RFC5545"/>. Any syntax elements shown below that are not explicitly defined in this specification come from iCalendar <xref target="RFC5545"/>.</t>

<t>Calendaring and scheduling roles are referred to in quoted-strings of text with the first character of each word in uppercase.  For example, "Organizer" refers to the role of a "Calendar User" (CU) within the scheduling protocol.</t>

<t>Calendar components defined by <xref target="RFC5545"/> and updating specifications are referred to with capitalized quoted-strings of text, followed by the words "calendar component".  For example, "VEVENT" calendar component refers to the event calendar component, "VTODO" calendar component refers to the to-do calendar component, and "VJOURNAL" calendar component refers to the daily journal calendar component.</t>

<t>Scheduling methods are referred to with capitalized quoted-strings of text.  For example, "REQUEST" refers to the method for requesting a scheduling calendar component be created or modified, and "REPLY" refers to the method the recipient of a request uses to update their status with the "Organizer" of the calendar component.</t>

<t>Properties defined by <xref target="RFC5545"/> and updating specifications are referred to with capitalized quoted-strings of text, followed by the word "property".  For example, the "ATTENDEE" property refers to the iCalendar property used to convey the calendar address of a "Calendar User".</t>

<t>Property parameters defined by <xref target="RFC5545"/> and updating specifications are referred to with lowercase quoted-strings of text, followed by the word "parameter".  For example, the "value" parameter refers to the iCalendar property parameter used to override the default data type for a property value.</t>

<t>Enumerated values defined by this specification are referred to with capitalized text, either alone or followed by the word "value".</t>

<t>In tables, the quoted-string text is specified without quotes in order to minimize the table length.</t>

<t anchor="terms">Terms defined and used in this specification include:</t>

<dl spacing="normal">

<dt>Assignee:</dt><dd><t>A calendar user assigned to perform a given task. An assignee is equivalent to an "Attendee" of a task.</t></dd>
<dt>BPMS:</dt><dd><t>Business Process Management Software</t></dd>
<dt>CU:</dt><dd><t>Calendar User. A person or software system that accesses or modifies calendar information.</t></dd>
<dt>CUA:</dt><dd><t>Calendar User Agent. This may be one of the following:</t>
<ol type="1" spacing="normal">
  <li>Software with which the CU communicates with a calendar service or local calendar store to access calendar information.</li>
  <li>Software that gathers calendar data on the CU's behalf.</li>
</ol>
</dd>
<dt>Candidate:</dt><dd><t>A calendar user who might be able to perform a given task, prior to actually being assigned the task, e.g., a dispatcher has a list of taxi drivers (candidates) from which one will be selected to pick up a passenger.</t></dd>
<dt>Organizer:</dt><dd><t>A calendar user who creates a calendar item, requests free/busy information, or publishes free/busy information. It is an "Organizer" who invites "Attendees"  <xref target="RFC5545"/>.</t></dd>
<dt>Observer:</dt><dd><t>A calendar user interested in a calendar component, e.g., a manager may have interest in all tasks that have not been completed. Often represented as an "Attendee" with the "role" parameter set to NON-PARTICIPANT.</t></dd>
<dt>Resource:</dt><dd><t>A resource in the scheduling context is any shared entity that can be scheduled by a calendar user but does not control its own attendance status. Examples of such resources are locations such as a bookable conference room or equipment such as projectors.</t></dd>
<dt>Task:</dt><dd><t>A representation of an item of work that can be assigned to one or more task actor assignees. In <xref target="RFC5545"/>, these are "VTODO" calendar components, which are groupings of component properties and possibly "VALARM" calendar components that represent an action item or assignment.</t>
</dd>
</dl>
</section>
</section>
    <section anchor="architecture"><name>Task Architecture</name>

<t>A reference architecture for task calendaring and scheduling is defined in order to identify the key logical elements involved in task management and the interfaces between them to enable interoperability. Central to this architecture is the Calendar and Scheduling System. The logical elements identified here establish an appropriate separation of concerns and clarify the responsibilities of different elements. However, the architecture does not prescribe the binding or packaging of elements, i.e., software systems may be developed where some elements are tightly bound and the interfaces between bound elements are not exposed. The task architecture is also described in  <xref target="TARCH"/>.</t>

<figure>
<name>Task Architecture Diagram</name>
<artwork align="center"><![CDATA[
  Task        +-------+
  Trigger             |
+---------------------V---------------------+    +-----------+
|           Task Generating System          |    |           |
|        +-------------------------+        |    |           |
|        |            O            |        |    |           |
|        |           /|\           |        |    |           |
|        |           / \           |        |    |           |
|        |      Task Organizer     |        <---->           |
|        +-^--------^--------------+        |    |           |
|          |        |                       |    |           |
| +--------V-+ +----V-----+    +----------+ |    |           |
| |   Task   | | Process  |    |   Task   | |    |           |
| |Assignment| |  Logic   <---->  Domain  | |    |           |
| |  Rules   | |          |    |   Data   | |    |           |
| +----------+ +----------+    +----------+ |    |           |
|                                           |    |           |
+------^----------+-----^-------------------+    |           |
       |          |     |                        |           |
  Availability  Task   Task                      |           |
       |          |   Status                     |           |
       |          |     |                        |           |
+------v----------v-----+-------------------+    |           |
|      Calendar and Scheduling System       |    | Directory |
| +---------+  +---------+                  |    |  Service  |
| |         |  |  Task   |                  <---->           |
| |Schedule |  |  Lists  |                  |    |           |
| |         |  |         |                  |    |           |
| +---------+  +---------+      Server      |    |           |
+-------------------------------------------+    |           |
|                               Client      |    |           |
| +----------------------+    +-----------+ |    |           |
| |       Calendar       |    |   Task    | |    |           |
| |      User Agent      +----> Specific  | <---->           |
| |                      |    |Application| |    |           |
| +----------------------+    +-----------+ |    |           |
|                                           |    |           |
+-----^---------^--------+---------+--------+    |           |
      |         |        |         |             |           |
+-----V---------V--------V---------V--------+    |           |
|                Task Actors                |    |           |
|     O         O        O         O        |    |           |
|    /|\       /|\      /|\       /|\       +---->           |
|    / \       / \      / \       / \       |    |           |
|          Candidate(s)        Observer(s)  |    |           |
| Assignee(s)       Resource(s)             |    |           |
+-------------------------------------------+    +-----------+]]></artwork></figure>

<section anchor="architecture-elements"><name>Task Architecture Elements</name>

<t>The following logical elements form the task architecture that this specification is based on:</t>

<dl spacing="normal" newline="true">
  <dt>Task Actors:</dt><dd><t>Various calendar users that may be involved in the monitoring or performing of a task. The set of actors includes Organizers, Observers, Resources, Assignees, and Candidates.</t></dd>
  <dt>Task Organizer:</dt><dd><t>The creator of a task who also determines task assignment and scheduling and monitors task progress.</t></dd>
  <dt>Task Domain Data:</dt><dd><t>This is any domain-specific data that may be acted on or that provides context for performing a task.</t></dd>
  <dt>Task-Specific Application:</dt><dd><t>A task-specific application renders the data concerning the task (including task domain data) for presentation and manipulation by a task actor.</t></dd>
  <dt>Process Logic:</dt><dd><t>Determines under what conditions one or more tasks are generated and the actions to take upon task completion or upon the occurrence (or non-occurrence) of some other status event.</t></dd>
  <dt>Task Trigger:</dt><dd><t>An event that gives rise to the generation of a task according to Process Logic. Task triggers can come from many sources including, for example, a task being requested through the calendaring system or a status change in the progression of a business process being managed by a business process management or enterprise resource planning (ERP) system.</t></dd>
  <dt>Task Assignment Rules:</dt><dd><t>Govern how actors are assigned to a task. A range of different assignment patterns  <xref target="WfRP"/> may be considered, including the two general cases:</t>
  <ol type="a">
    <li>Delegation to a named actor or group of actors</li>
    <li>Advertising to a pool of actors for self-selection</li>
  </ol>
<t>In either case, the assignment may be made based on a variety of criteria including, name, availability, skills, capacity, etc.</t></dd>
<dt>Task Generating System:</dt><dd><t>A system that creates and assigns tasks in response to some initiating event (task trigger). 

Process Logic defines task creation, while Task Assignment Rules determine task assignment. This system also tracks the status of tasks and will initiate further actions based upon the status. A Task Generating System can take many forms, such as a Business Process Management System, Project Management System, Bug Tracking System, and Building Control System. A Task Generating System may also be a human. In iCalendar terms the Task Generating System is the "Organizer".</t>
<t>Task creation, assignment, and tracking coordinated by a human "Organizer" is a special case of a Task Generating System. In this case, Task Assignment Rules and Process Logic may be either explicit or tacit.</t></dd>
<dt>Calendar and Scheduling System:</dt><dd><t>A software system that stores, publishes, and synchronizes calendar data such as events, tasks, and journal entries for actors. In the context of tasks, this includes schedules (i.e., allocated time and availability to perform tasks) and task lists. A calendar and scheduling system typically consists of server and client software components.</t>
</dd>
</dl>

<t>It is not within the scope of this document to specify how Process Logic or Task Assignment Rules are codified. Such logic and rules may be codified in a variety of ways, including conventional programming languages (e.g., C++ and Java) or process modeling languages (e.g., Business Process Model and Notation (BPMN) <xref target="BPMN"/>).</t>
</section>

<section anchor="architecture-foundations"><name>Architecture Foundations</name>

<t>The key standards that enable interoperability between the logical elements of the architecture are iCalendar  
<xref target="RFC5545"/> and the associated protocols. Task and task status are represented by the "VTODO" calendar component. Protocols include, in particular, the iCalendar Transport-Independent Interoperability Protocol (iTIP)  <xref target="RFC5546"/> for task assignment and scheduling and the Calendaring Extensions to WebDAV (CalDAV)  <xref target="RFC4791"/> for client server communication.</t>

<t>Additionally, this specification uses definitions from "Support for iCalendar Relationships"  <xref target="RFC9253"/>. The "LINK", "REFID", "RELATED-TO", and "CONCEPT" properties enable context and a rich set of relationships between tasks and other calendar components to be specified.</t>
</section>
</section>
    <section anchor="task-extensions"><name>Task Extensions</name>

<t>In order to support the task architecture described in <xref target="architecture"/>, this document defines a number of extensions to iCalendar <xref target="RFC5545"/> in the following areas:</t>

<dl spacing="normal" newline="true">
  <dt>Task Specification:</dt><dd><t>Improved ability to specify domain-specific tasks.</t></dd>
  <dt>Task Deadlines, Milestones, and Time Planning:</dt><dd><t>Clarification of deadlines and extension for task duration to support task time planning.</t></dd>
  <dt>Task Scheduling and Assignment:</dt><dd><t>Ensure support for common patterns of scheduling and assigning tasks.</t></dd>
  <dt>Task Status Tracking:</dt><dd><t>Improved granularity in status tracking information and alerting task actors of pending or actual task status changes.</t></dd>
</dl>

<t>These extensions are supported mainly by additions to the properties and parameters used within the "VTODO" calendar component.</t>
</section>
    <section anchor="task-specification"><name>Task Specification</name>

<t>The specification of tasks must be semantically explicit in order for them to be managed within the context of a business process or project and understood by both humans and IT systems. The "VTODO" calendar component <xref target="RFC5545"/> only provides for simple ad hoc tasks or to-do lists and is therefore extended by this specification as follows:</t>

<dl spacing="normal" newline="true">
  <dt>Task Type:</dt><dd><t>Explicitly what type of task is to be performed is identified.</t></dd>
  <dt>Task Context and Relationships:</dt><dd><t>How a specific task relates to other tasks and other objects that need to be understood for the effective execution of a task.</t></dd>
  <dt>Task-Specific Data:</dt><dd><t>The form and content of domain data provided as input to a task and/or that may be output from a task.</t></dd>
  <dt>Organizer and Attendee:</dt><dd><t>Recognizes that a task "Organizer" or "Attendee" can be an automated system.</t></dd>
</dl>

<section><name>Task Type</name>

<t>The "CONCEPT" property <xref target="RFC9253"/> is used to identify the type of task, for example:</t>

<sourcecode type="text/calendar"><![CDATA[
CONCEPT:http://example.com/task/delivery]]></sourcecode>

</section>

<section><name>Task Context and Relationships</name>

<t>The "LINK" property <xref target="RFC9253"/> specifies a link to external information, which may provide context for the task. For example:</t>

<sourcecode type="text/calendar"><![CDATA[
LINK;LINKREL=describedby;VALUE=URI:
 mid:752142.141482.307E5@mx123.example.com]]></sourcecode>


<t>The external information may consist of data to be manipulated in performing the task.</t>

<t>The "LINK" property can be used to relate a domain-specific service to the task. For example, it might be a URI pointing to a web page where the status of the task can be directly manipulated.</t>

<t>Note: The link relations below are for illustration only.</t>

<sourcecode type="text/calendar"><![CDATA[
LINK;LINKREL="vacation-system";VALUE=URI:
 http://example.com/vacation-approval?id=1234]]></sourcecode>


<t>Additionally, it might be used to link data specific to the task, for example, an electronic copy of a signature taken to confirm delivery of a package.</t>

<sourcecode type="text/calendar"><![CDATA[
LINK;LINKREL="electronic-signature";VALUE=URI:
 http://example.com/delivery/sig1234.jpg]]></sourcecode>


<t>The "REFID" property <xref target="RFC9253"/> is used to identify a key used to group tasks by that key.</t>

<sourcecode type="text/calendar"><![CDATA[
REFID:Manhattan

REFID:1234567890]]></sourcecode>


<t>Extensions to the "RELATED-TO" property defined in <xref target="RFC9253"/> allow temporal relationships between tasks as found in project management to be specified as well as parent/child relationships and dependencies (DEPENDS-ON). Tasks ("VTODO" calendar components) may also be related to other calendar components, for example, a "VEVENT" calendar component used to block time to perform a task.</t>
</section>
</section>
    <section anchor="deadlines"><name>Task Deadlines, Milestones, and Time Planning</name>

<section><name>Deadlines</name>

<t>Deadlines for starting and finishing a task are defined by the "DTSTART", "DUE", and "DURATION" properties. The "DTSTART" property represents the earliest start time for beginning work on a task. The "DUE" or "DTSTART" + "DURATION" properties represent the latest finish time for a task. Thus, these properties define a "window" within which a task has to be performed. However,  <xref target="RFC5545"/> provides no way to indicate how long the task is expected to take. This document defines a new "ESTIMATED-DURATION" property, in  <xref target="prop-estimated-duration"/>, to allow the estimated time that a task should take to be specified separately from the deadlines for starting and finishing a task. This supports time planning by enabling calendar user agents to display when tasks should occur, which allows calendar users to visualize when tasks should be performed and to allocate time to them accordingly.</t>
</section>

<section><name>Milestones</name>

<t>A task that has intermediary deadlines (i.e., milestones) <bcp14>MUST</bcp14> be expressed by child "VTODO" calendar components (i.e., subtasks associated with each of the milestones) in conjunction with the "RELATED-TO" property to relate the parent and child tasks.</t>
</section>
</section>
    <section anchor="scheduling-assignment"><name>Task Scheduling and Assignment</name>

<t>Tasks are assigned to actors using one or more "ATTENDEE" properties <xref target="RFC5545"/> and/or one or more  "PARTICIPANT" calendar components <xref target="RFC9073"/>, as described in <xref target="attendee-participant"/>.</t>

<t>Communication of task assignment or delegation to one or more actors who are allocated to a task by the "Organizer" is directly supported by iTIP, i.e., all included "ATTENDEE" properties in an iTIP "REQUEST" are expected to perform the task.</t>

<t>The offering or advertising of a task to one or more (potential) actors where only one or a subset of the candidates may accept the task will be addressed by a later specification.</t>
</section>
    <section anchor="status-reporting"><name>Status Reporting</name>

<section><name>Improved Granularity in Status Reporting Information</name>

<t>This document defines a new "VSTATUS" calendar component (see <xref target="vstatus"/>) that can be used to group related information about the status of the task. This might include information on why (the "REASON" property) and when (the "DTSTAMP" property) a status has changed. In addition, new status values are specified to provide for task suspension, failure, and preparation.</t>

<sourcecode type="text/calendar"><![CDATA[
BEGIN:VSTATUS
STATUS:FAILED
REASON:https://example.com/reason/delivery-failed
SUBSTATE:ERROR
DTSTAMP:20130212T120000Z
COMMENT:Breakdown
END:VSTATUS]]></sourcecode>

</section>

<section><name>Comments Associated to Reasons and Status Changes</name>

<t>Multiple comments and reasons may have the same status. As situations change, further "VSTATUS" calendar components can be added to provide additional information.</t>

<sourcecode type="text/calendar"><![CDATA[
CONCEPT:https://example.com/task/delivery
BEGIN:VSTATUS
STATUS:FAILED
SUBSTATE:ERROR
DTSTAMP:20220212T104900Z
COMMENT:Out of time
END:VSTATUS
BEGIN:VSTATUS
STATUS:FAILED
COMMENT:Traffic Accident on E44
REASON:https://example.com/reason/traffic
DTSTAMP:20220212T110451Z
END:VSTATUS
BEGIN:VSTATUS
STATUS:FAILED
COMMENT:Arrived after office hours
REASON:https://example.com/reason/closed
DTSTAMP:20220212T180451Z
END:VSTATUS]]></sourcecode>


<t>Note that the "VSTATUS" calendar component is not intended to be used as a history of changes to a task's properties. The purpose of the "VSTATUS" calendar component is only to document changes related to fulfilling the tasks.</t>
</section>

<section><name>Updating the Overall Status</name>

<t>Only the Task Organizer, or the server acting as the Organizer's proxy, may change or add "VSTATUS" calendar components and the "STATUS" property.</t>

<t>The overall "VSTATUS" will be changed in response to incoming "Attendee" replies. Each change of the overall "VSTATUS" <bcp14>MUST</bcp14> be accompanied by a change to the STATUS.</t>

<t>Note there is no defined ordering of properties and components so the DTSTAMP property <bcp14>SHOULD</bcp14> be set for each "VSTATUS" component to preserve ordering.</t>
</section>

<section anchor="attendee-participant"><name>Relating Reason and Comments to "ATTENDEE" Property Status Changes</name>

<t>The "PARTICIPANT" calendar component <xref target="RFC9073"/> can be used to provide additional information about why an "ATTENDEE" property's participation status has changed, by following the guidelines set out in <xref target="RFC9073" section="7.1"/>. The "COMMENT" property can also be used to include additional human-readable information about why the associated "STATUS" or "ATTENDEE" property changed. For example, if a driver failed to deliver a package because of a puncture, it might be expressed as</t>

<sourcecode type="text/calendar"><![CDATA[
ATTENDEE;PARTSTAT=FAILED:mailto:xxx@example.com
...
BEGIN:PARTICIPANT
CALENDAR-ADDRESS:mailto:xxx@example.com
DTSTAMP:20130226T1104510Z
REASON:https://example.com/reason/van-break-down
COMMENT:Puncture
END:PARTICIPANT]]></sourcecode>

</section>

<section><name>Task Alerts and Notifications</name>

<t>Different requirements to alert or notify task actors of pending or actual task status changes are recognized:</t>

<dl spacing="normal" newline="true">
  <dt>Alarms:</dt>
  <dd><t>"VALARM" calendar components operate in the calendar user agent space to notify the task actor of a pending task state for a task they are assigned to or are interested in.</t>
  <t>Current standards (such as <xref target="RFC9074"/>) indicate that "VALARM" calendar components <bcp14>SHOULD</bcp14> be removed from incoming data, and many systems in fact do so. In a task assignment scenario, it may be appropriate for the "Organizer" to be able to set alarms for the participants. A system implementing these standards may choose to preserve "VALARM" calendar components, but sending a task via some external service may result in their removal. This issue is not addressed by this specification.</t>
  </dd>
  <dt>Escalations:</dt>
  <dd><t>An escalation or notification to the "Attendee", "Organizer", or other task actor may be required if a deadline associated with a task is exceeded or for some other reason. Process Logic identifying when and who to propagate escalations is the responsibility of the Task Generating System, e.g., a BPMS.</t>
  </dd>
  <dt>Notifications:</dt>
  <dd><t>Task actors (Observers) not directly involved in performing a task but that have a known interest in a given task's status can be identified by the "PARTICIPANT" calendar component <xref target="RFC9073"/> against certain components, e.g., the "VALARM" calendar component, to identify which task events the stakeholder/party is interested in. Notifications on shared calendars will allow task actors to register an interest in changes to tasks within a calendar (see  <xref target="appendix-a"/>).</t></dd>
</dl>
</section>

<section><name>Automated Status Changes</name>

<t>A new "TASK-MODE" property is introduced to instruct servers to apply automated operations for changing the status of a task.</t>
</section>
</section>
    <section anchor="modifications-to-calendar-components"><name>Modifications to Calendar Components</name>

<t>The following changes to the syntax defined in iCalendar <xref target="RFC5545"/> and Event Publishing Extensions to iCalendar  <xref target="RFC9073"/> are made here. New elements are defined in subsequent sections.</t>

<sourcecode type="abnf"><![CDATA[
; Addition of VSTATUS as a valid component for VEVENT
eventc     = "BEGIN" ":" "VEVENT" CRLF
             eventprop *alarmc *participantc *locationc
                 *resourcec *statusc
             "END" ":" "VEVENT" CRLF

; Addition of VSTATUS as a valid component for VTODO
todoc      = "BEGIN" ":" "VTODO" CRLF
             todoprop *alarmc *participantc *locationc
                 *resourcec *statusc
             "END" ":" "VTODO" CRLF

; Addition of properties ESTIMATED-DURATION and TASK-MODE to VTODO
todoprop =/ est-duration /
            task-mode

; Addition of VSTATUS as a valid component for VJOURNAL
journalc   = "BEGIN" ":" "VJOURNAL" CRLF
              jourprop *statusc
              "END" ":" "VJOURNAL" CRLF


; Addition of VSTATUS as a valid component for VFREEBUSY
freebusyc  = "BEGIN" ":" "VFREEBUSY" CRLF
             fbprop *participantc *locationc *resourcec *statusc
             "END" ":" "VFREEBUSY" CRLF

; Addition of VSTATUS as a valid component for PARTICIPANT
participantc = "BEGIN" ":" "PARTICIPANT" CRLF
               partprop *locationc *resourcec
               *statusc
               "END" ":" "PARTICIPANT" CRLF


; Addition of properties PERCENT-COMPLETE and REASON to PARTICIPANT
partprop =/ percent / ; OPTIONAL but MUST NOT occur more than once.
            reason    ; OPTIONAL but MUST NOT occur more than once.]]></sourcecode>

</section>
    <section anchor="new-parameter-values"><name>New Parameter Values</name>

<section anchor="param-val-partstat"><name>Redefined VTODO Participant Status</name>

<t>Participant status parameter type values are defined in <xref target="RFC5545" section="3.2.12"/>.  This specification redefines that type to include the new value "FAILED" for "VTODO" calendar components.</t>

<dl spacing="normal" newline="true">
  <dt>Format Definition:</dt><dd><t>This property parameter is redefined by the following notation, which adds the value "FAILED":</t>

<sourcecode type="abnf"><![CDATA[
partstat-todo    = ("NEEDS-ACTION"    ; To-do needs action
                 / "ACCEPTED"         ; To-do accepted
                 / "DECLINED"         ; To-do declined
                 / "TENTATIVE"        ; To-do tentatively
                                      ; accepted
                 / "DELEGATED"        ; To-do delegated
                 / "COMPLETED"        ; To-do completed
                                      ; COMPLETED property has
                                      ; DATE-TIME completed
                 / "IN-PROCESS"       ; To-do in process of
                                      ; being completed
                 / "FAILED"           ; To-do cannot be
                                      ; completed
                 / x-name             ; Experimental status
                 / iana-token)        ; Other IANA-registered
                                      ; status
; These are the participation statuses for a "VTODO".
; Default is NEEDS-ACTION.]]></sourcecode></dd>

<dt>Example:</dt>

<dd><sourcecode type="text/calendar"><![CDATA[
ATTENDEE;REASON="https://example.com/reason/not-enough-time";
 PARTSTAT=FAILED:mailto:jsmith@example.com]]></sourcecode></dd>
</dl>

</section>
</section>
    <section anchor="new-properties"><name>New Properties</name>

<section anchor="prop-estimated-duration"><name>Estimated Duration</name>

<dl spacing="normal" newline="true">
  <dt>Property Name:</dt><dd><t>ESTIMATED-DURATION</t></dd>
  <dt>Purpose:</dt><dd><t>This property specifies the estimated positive duration of time the corresponding task will take to complete.</t></dd>
  <dt>Value Type:</dt><dd><t>DURATION</t></dd>
  <dt>Property Parameters:</dt><dd><t>IANA and non-standard property parameters can be specified on this property.</t></dd>
  <dt>Conformance:</dt><dd><t>This property can be specified in "VTODO" calendar components.</t></dd>
  <dt>Format Definition:</dt><dd><t>This property is defined by the following notation:</t>

<sourcecode type="abnf"><![CDATA[
est-duration  = "ESTIMATED-DURATION" durparam ":" dur-value CRLF
                ;consisting of a positive duration of time.

durparam      = *(";" other-param)]]></sourcecode></dd>

  <dt>Description:</dt><dd><t>In a "VTODO" calendar component the property <bcp14>MAY</bcp14> be used to specify the estimated duration for the to-do, with or without an explicit time window in which the event should be started and completed. When present, the "DTSTART" and "DUE" or "DTSTART" and "DURATION" properties represent the window in which the task can be performed. The "ESTIMATED-DURATION" property <bcp14>SHOULD</bcp14> be passed from the "Organizer" to the "Attendee" in iTIP  <xref target="RFC5546"/> messages.</t></dd>
  <dt>Example:</dt><dd><t>The following example illustrates how this property is used to estimate a task duration of one hour:</t>

<sourcecode type="text/calendar"><![CDATA[
ESTIMATED-DURATION:PT1H]]></sourcecode></dd>
</dl>
</section>

<section anchor="prop-reason"><name>Reason</name>

<dl spacing="normal" newline="true">
<dt>Property Name:</dt><dd><t>REASON</t>
</dd><dt>Purpose:</dt><dd><t>To indicate the reason for a status change or change of "Attendee" participation status.</t></dd>
<dt>Value Type:</dt><dd><t>URI</t></dd>
<dt>Property Parameters:</dt><dd><t>IANA and non-standard property parameters can be specified on this property.</t></dd>
<dt>Conformance:</dt><dd><t>This property can be specified in "VSTATUS" and "PARTICIPANT" calendar components.</t></dd>
<dt>Format Definition:</dt><dd><t>This property is defined by the following notation:</t>

<sourcecode type="abnf"><![CDATA[
reason      = "REASON" reasonparam ":" uri CRLF

reasonparam = *(";" other-param)]]></sourcecode></dd>

  <dt>Description:</dt><dd><t>This property allows a change in task or participant status to be qualified with a codified reason. Typically, reasons are defined within the context of the task type and therefore <bcp14>SHOULD</bcp14> include the name-space of the authority defining the task.</t></dd>
  <dt>Example:</dt>

<dd><sourcecode type="text/calendar"><![CDATA[
REASON:https://example.com/reason/delivered-on-time]]></sourcecode></dd>
</dl>

</section>

<section anchor="prop-substate"><name>Substate</name>

<dl spacing="normal" newline="true">
  <dt>Property Name:</dt><dd><t>SUBSTATE</t></dd>
  <dt>Purpose:</dt><dd><t>To provide additional granularity of a task status, such as IN-PROCESS.</t></dd>
  <dt>Value Type:</dt><dd><t>TEXT</t></dd>
  <dt>Property Parameters:</dt><dd><t>IANA and non-standard property parameters can be specified on this property.</t></dd>
  <dt>Conformance:</dt><dd><t>This property can be specified in a "VSTATUS" calendar component.</t></dd>
  <dt>Format Definition:</dt><dd><t>This property is defined by the following notation:</t>

<sourcecode type="abnf"><![CDATA[
substate         = "SUBSTATE" substateparam ":" substatevalue CRLF

substateparam    = *(";" other-param)

substatevalue    = ("OK"        ; everything is fine (the default)
                  / "ERROR"     ; something is wrong (REASON
                  ;               explains why)
                  / "SUSPENDED" ; waiting on some other task to
                  ;               complete or availability of a
                  ;               resource (REASON explains why)
                  / iana-token) ; other IANA-registered type
]]></sourcecode></dd>

  <dt>Description:</dt><dd><t>The "SUBSTATE" property allows additional qualification and granularity of states to be recorded, in particular for the IN-PROCESS state. It allows individual substates to be recorded without the need to define and publish a subtask associated with a parent task purely to track that a particular state has been reached. This property also allows parallel states to be expressed, such as indicating that a task has been suspended at whatever state it has reached.</t></dd>
<dt>Example:</dt>

<dd><sourcecode type="text/calendar"><![CDATA[
BEGIN:VSTATUS
STATUS:FAILED
REASON:https://example.com/reason/no-one-home
SUBSTATE:ERROR
END:VSTATUS

BEGIN:VSTATUS
STATUS:IN-PROCESS
REASON:https://example.com/reason/paint-drying
SUBSTATE:SUSPENDED
END:VSTATUS]]></sourcecode></dd>
</dl>
</section>

<section anchor="prop-task-mode"><name>Task Mode</name>

<dl spacing="normal" newline="true">
  <dt>Property Name:</dt><dd><t>TASK-MODE</t></dd>
  <dt>Purpose:</dt><dd><t>This property specifies automatic operations that servers acting on behalf of the "Organizer" apply to tasks based on changes in "Attendee" status (PARTSTAT).</t></dd>
  <dt>Value Type:</dt><dd><t>TEXT</t></dd>
  <dt>Property Parameters:</dt><dd><t>IANA and non-standard property parameters can be specified on this property.</t></dd>
  <dt>Conformance:</dt><dd><t>This property can be specified zero times or once in a "VTODO" calendar component.</t></dd>
  <dt>Format Definition:</dt><dd><t>This property is defined by the following notation:</t>

<sourcecode type="abnf"><![CDATA[
task-mode   = "TASK-MODE" taskmodeparam ":"
                 ("AUTOMATIC-COMPLETION"
                 / "AUTOMATIC-FAILURE"
                 / "AUTOMATIC"
                 / "SERVER"
                 / "CLIENT"
                 / iana-token) CRLF

taskmodeparam      = *(";" other-param)]]></sourcecode></dd>

  <dt>Description:</dt><dd><t>In a "VTODO" calendar component, this property <bcp14>MAY</bcp14> be used to indicate to servers how they can automatically change the state of the task based on iTIP replies from "Attendees". For example, the server can automatically set the overall task status to "COMPLETED" when every "Attendee" has marked their own status (PARTSTAT) as "COMPLETED", or the server could mark the task as "FAILED" if its DUE date passes before completion. "TASK-MODE" processing is performed on the "Organizer's" copy of the task.</t>
  <t>To set the status, add a "VSTATUS" component as specified in <xref target="vstatus"/>.</t>

  <t>The property value is an IANA-registered token that defines the mode to be used for the task. The modes are described in the following subsections.</t>

  <t>If the "TASK-MODE" property is absent, then the "CLIENT" value is assumed.</t></dd>

  <dt>AUTOMATIC-COMPLETION Task Mode:</dt><dd><t>The task mode value "AUTOMATIC-COMPLETION" indicates to the server that it <bcp14>SHOULD</bcp14> change the "VTODO" calendar component's status to "COMPLETED" as soon as all "Attendees" in the task have replied with a "partstat" parameter set to "COMPLETED".</t>
  <t>Failing the task <bcp14>MUST</bcp14> be handled by a client.</t></dd>

  <dt>AUTOMATIC-FAILURE Task Mode:</dt><dd><t>The task mode value "AUTOMATIC-FAILURE" indicates to the server that it <bcp14>SHOULD</bcp14> change the "VTODO" calendar component's status to "FAILED" if either:</t>
  <ol type="1">
    <li>the PARTSTAT of one "ATTENDEE" property is set to "FAILED"; or</li>
    <li><t>the current time is past the effective due date of the component and the task has not yet been completed. The effective due date is either the "DUE" property value or the combination of the "DTSTART" and "DURATION" property values.</t>
    <t>Completing the task <bcp14>MUST</bcp14> be handled by a client.</t>
    </li>
  </ol>
</dd>

<dt>AUTOMATIC Task Mode:</dt><dd><t>This mode handles the automatic behavior of both "AUTOMATIC-COMPLETION" and "AUTOMATIC-FAILURE".</t></dd>

<dt>CLIENT Task Mode:</dt><dd><t>The task mode value "CLIENT" is an instruction to the server to honor the status set by the client.</t></dd>

<dt>SERVER Task Mode:</dt><dd><t>The task mode value "SERVER" indicates to the server that it <bcp14>SHOULD</bcp14> change the "VTODO" calendar component's status to an appropriate value, based on implementation-defined "business rules", as "Attendee" responses are processed or as deadlines related to the task pass.</t>
</dd>
<dt>Examples:</dt><dd>

<sourcecode type="text/calendar"><![CDATA[
TASK-MODE:AUTOMATIC-COMPLETION
TASK-MODE:AUTOMATIC-FAILURE
TASK-MODE:SERVER]]></sourcecode>
</dd>
</dl>
</section>
</section>
    <section anchor="property-extensions"><name>Property Extensions and Clarifications</name>

<section anchor="prop-ext-duration"><name>Updated DURATION Property Definition for VTODO</name>

<t><xref target="RFC5545" section="3.6.2"/> introduces a constraint on the use of the "DURATION" property in the "VTODO" calendar component, requiring that a "DURATION" property <bcp14>MUST</bcp14> be accompanied by a "DTSTART" property. This constraint is now dropped, reverting to the situation as specified previously. Thus, <xref target="RFC5545" section="3.6.2"/> is updated as follows:</t>

<t>OLD TEXT:</t>

<sourcecode type=""><![CDATA[
; Either 'due' or 'duration' MAY appear in
; a 'todoprop', but 'due' and 'duration'
; MUST NOT occur in the same 'todoprop'.
; If 'duration' appear in a 'todoprop',
; then 'dtstart' MUST also appear in
; the same 'todoprop'.]]></sourcecode>

<t>NEW TEXT:</t>

<sourcecode type=""><![CDATA[
; Either 'due' or 'duration' MAY appear in
; a 'todoprop', but 'due' and 'duration'
; MUST NOT occur in the same 'todoprop'.]]></sourcecode>

<t>Note: This allows a "VTODO" calendar component to only have a "DURATION" property.</t>

<t>OLD TEXT:</t>

<blockquote>
     A "VTODO" calendar component without 
     the "DTSTART" and "DUE" (or
     "DURATION") properties specifies a to-do that will be associated
     with each successive calendar date, until it is completed.</blockquote>

<t>NEW TEXT:</t>

<blockquote>
     A "VTODO" calendar component without the "DTSTART" and "DUE"
     properties specifies a to-do that will be associated
     with each successive calendar date, until it is completed.</blockquote>
</section>

<section anchor="prop-ext-status"><name>Redefined STATUS Property</name>

<t>The "STATUS" property is defined in <xref target="RFC5545" section="3.8.1.11"/>. This specification extends that property to include new values associated with "VTODO" calendar components (see <xref target="appendix-a"/> for examples of the task state lifecycle).</t>

<dl spacing="normal" newline="true">
  <dt>Format Definition:</dt><dd><t>The "STATUS" property parameter list for tasks is redefined by the addition of the values "PENDING" and "FAILED":</t>

<sourcecode type="abnf"><![CDATA[
statvalue-todo  = "NEEDS-ACTION" ; To-do needs action.
                / "COMPLETED"    ; To-do completed.
                / "IN-PROCESS"   ; To-do in process of.
                / "CANCELLED"    ; To-do was cancelled.
                / "PENDING"      ; A to-do has been
                                 ;   created and accepted, but
                                 ;   has not yet started.
                / "FAILED"       ; To-do has failed.
; Extended status values for "VTODO" calendar component.
]]></sourcecode></dd>

  <dt>Description:</dt>
  <dd>
    <dl spacing="normal" newline="false">
      <dt>PENDING:</dt><dd>A to-do has been created and accepted but has not
      yet started and is ready to start subject to other dependencies
      (e.g., a preceding task or DTSTART). This is the default state.</dd>
      <dt>FAILED:</dt><dd>A to-do has failed and may need some follow-up from the
      "Organizer" to reschedule or cancel.</dd>
    </dl>
  </dd>
<dt>Example:</dt><dd><t>The following is an example of this property for a "VTODO" calendar component:</t>
<sourcecode type="text/calendar"><![CDATA[
STATUS:FAILED]]></sourcecode></dd>
</dl>

</section>
</section>
    <section anchor="new-components"><name>New Components</name>

<section anchor="vstatus"><name>Status Component</name>

<dl spacing="normal" newline="true">
  <dt>Component Name:</dt><dd><t>VSTATUS</t></dd>
  <dt>Purpose:</dt><dd><t>This component allows information to be associated with a status, for example, comments and date stamps.</t></dd>
  <dt>Conformance:</dt><dd><t>This component can be specified multiple times in any calendar component.</t></dd>
  <dt>Description:</dt><dd><t>This component provides a way for multiple date-stamped statuses to be associated with a component such as a participant, task, or event.</t></dd>
</dl>

<t>This component may be added to the "PARTICIPANT" component <xref target="RFC9073"/> to allow participants in a task to specify their own status.</t>

<t>For backwards compatibility, when a "VSTATUS" component is added, the "STATUS" property <xref target="RFC5545"/> <bcp14>MUST</bcp14> be set on the parent component.</t>

<dl spacing="normal" newline="true">
  <dt>Format Definition:</dt><dd><t>This component is defined by the following notation:</t>

<sourcecode type="abnf"><![CDATA[
statusc      = "BEGIN" ":" "VSTATUS" CRLF
               statusprop
               "END" ":" "VSTATUS" CRLF

statusprop   = *(
             ;
             ; The following is REQUIRED,
             ; but MUST NOT occur more than once.
             ;
             status /
             ;
             ; The following are OPTIONAL,
             ; but MUST NOT occur more than once.
             ;
             description / dtstamp / reason / substate / summary /
             ;
             ; The following are OPTIONAL,
             ; and MAY occur more than once.
             ;
             comment / styleddescription / iana-prop
             ;
             )
]]></sourcecode></dd>

<dt>Examples:</dt><dd>
<sourcecode type="text/calendar"><![CDATA[
BEGIN:VSTATUS
STATUS:COMPLETED
REASON: https://example.com/reason/delivered-on-time
DTSTAMP:20220212T120000Z
END:VSTATUS]]></sourcecode>
</dd>
</dl>

</section>
</section>
    <section anchor="caldav-support"><name>CalDAV Support for Task Mode</name>

<t>The CalDAV <xref target="RFC4791"/> calendar access protocol allows clients and servers to exchange iCalendar data. With the introduction of the "TASK-MODE" property in this specification, different automated task management behaviors may be delegated to the server by the Task Organizer depending upon the value of "TASK-MODE".</t>

<t>In order for a CalDAV client to know what task modes are available, a CalDAV server advertises a CALDAV:supported-task-mode-set WebDAV property on calendar home or calendar collections if it supports the use of the "TASK-MODE" property as described in this specification.  The server can advertise a specific set of supported task modes by including one or more CALDAV:supported-task-mode XML elements within the CALDAV:supported-task-mode-set XML element.</t>

<t>If no CALDAV:supported-task-mode XML elements are included in the WebDAV property, then clients <bcp14>MUST</bcp14> assume the server does not support this specification. The client <bcp14>MAY</bcp14> attempt to store iCalendar data containing "TASK-MODE" elements but needs to be prepared for a failure response from the server.</t>

<t>A server supporting this specification <bcp14>MUST</bcp14> return an HTTP 403 response with a DAV:error element containing a CALDAV:supported-task-mode XML element, if a client attempts to store iCalendar data with a "TASK-MODE" element value not supported by the server.</t>

<t>It is possible for a "TASK-MODE" value to be present in calendar data on the server being accessed by a client that does not support the "TASK-MODE" property. It is expected that existing clients, unaware of "TASK-MODE", will fail gracefully by ignoring the calendar property.</t>

<section><name>CALDAV:supported-task-mode-set Property</name>

<dl spacing="normal" newline="true">
<dt>Name:</dt><dd><t>supported-task-mode-set</t></dd>
<dt>Namespace:</dt><dd><t>urn:ietf:params:xml:ns:caldav</t></dd>
<dt>Purpose:</dt><dd><t>Enumerates the set of supported iCalendar "TASK-MODE" element values supported by the server.</t></dd>
<dt>Protected:</dt><dd><t>This property <bcp14>MUST</bcp14> be protected and <bcp14>SHOULD NOT</bcp14> be returned by a PROPFIND allprop request (as defined in <xref target="RFC4918" section="14.2"/>).</t></dd>
<dt>Description:</dt><dd><t>See above.</t></dd>
<dt>Definition:</dt><dd>
<sourcecode type="dtd"><![CDATA[
<!ELEMENT supported-task-mode-set(supported-task-mode*)>
<!ELEMENT supported-task-mode (#PCDATA)>
<!-- PCDATA value: string - case insensitive but
uppercase preferred -->]]></sourcecode>
</dd>

<dt>Example:</dt>
<dd>
<sourcecode type="xml"><![CDATA[
<C:supported-task-mode-set 
   xmlns:C="urn:ietf:params:xml:ns:caldav">
  <C:supported-task-mode>AUTOMATIC</C:supported-task-mode>
  <C:supported-task-mode>SERVER</C:supported-task-mode>
  <C:supported-task-mode>CLIENT</C:supported-task-mode>
</C:supported-task-mode-set>]]></sourcecode>
</dd>
</dl>

</section>
</section>
    <section anchor="security"><name>Security Considerations</name>

<t>This specification introduces no new security considerations beyond those identified in <xref target="RFC5545"/>, <xref target="RFC5546"/>, <xref target="RFC4791"/>, and <xref target="RFC9253"/>.</t>
</section>
    <section anchor="iana"><name>IANA Considerations</name>

<section><name>Component Registration</name>

<t>IANA has added the following new iCalendar component to the "Components" registry defined in <xref target="RFC5545" section="8.3.1"/> and located on <eref target="https://www.iana.org/assignments/icalendar" brackets="angle"/>.</t>

<table>
  <name>Addition to the Components Registry</name>
  <thead>
    <tr>
      <th align="left">Component</th>
      <th align="left">Status</th>
      <th align="left">Reference</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left"><t>VSTATUS</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="vstatus"/> of RFC 10051</t></td>
    </tr>
  </tbody>
</table>
</section>

<section><name>Property Registrations</name>

<t>IANA has added the following new iCalendar properties to the "Properties" registry defined in <xref target="RFC5545" section="8.3.2"/> and located on <eref target="https://www.iana.org/assignments/icalendar" brackets="angle"/>.</t>

<table>
  <name>Additions to the Properties Registry</name>
  <thead>
    <tr>
      <th align="left">Property</th>
      <th align="left">Status</th>
      <th align="left">Reference</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left"><t>ESTIMATED-DURATION</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-estimated-duration"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>REASON</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-reason"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>SUBSTATE</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-substate"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>STATUS</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-ext-status"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>TASK-MODE</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-task-mode"/> of RFC 10051</t></td>
    </tr>
  </tbody>
</table>

</section>

<section><name>STATUS Values Registry</name>

<t>IANA has created a new iCalendar registry called "STATUS Values" for values of the "STATUS" property defined in <xref target="RFC5545" section="3.8.1.11"/>.</t>

<t>Additional values <bcp14>MAY</bcp14> be used, provided the process of Standards Action with Expert Review as described in <xref section="8.2.1" target="RFC5545"/> is used to register them, using the template in <xref section="8.2.6" target="RFC5545"/>.</t>

<t>The initial contents of the "STATUS Values" registry are as follows:</t>

<table>
  <name>Initial Contents of the STATUS Values Registry</name>
  <thead>
    <tr>
      <th align="left">Name</th>
      <th align="left">Status</th>
      <th align="left">Reference</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left"><t>CANCELLED</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="RFC5545" section="3.8.1.11"/></t></td>
    </tr>
    <tr>
      <td align="left"><t>COMPLETED</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="RFC5545" section="3.8.1.11"/></t></td>
    </tr>
    <tr>
      <td align="left"><t>CONFIRMED</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="RFC5545" section="3.8.1.11"/></t></td>
    </tr>
    <tr>
      <td align="left"><t>DRAFT</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="RFC5545" section="3.8.1.11"/></t></td>
    </tr>
    <tr>
      <td align="left"><t>FAILED</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-ext-status"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>FINAL</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="RFC5545" section="3.8.1.11"/></t></td>
    </tr>
    <tr>
      <td align="left"><t>IN-PROCESS</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="RFC5545" section="3.8.1.11"/></t></td>
    </tr>
    <tr>
      <td align="left"><t>NEEDS-ACTION</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="RFC5545" section="3.8.1.11"/></t></td>
    </tr>
    <tr>
      <td align="left"><t>PENDING</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-ext-status"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>TENTATIVE</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="RFC5545" section="3.8.1.11"/></t></td>
    </tr>
  </tbody>
</table>
</section>

<section><name>SUBSTATE Values Registry</name>

<t>IANA has created a new iCalendar registry called "SUBSTATE Values" for values of the "SUBSTATE" property defined in <xref target="prop-substate"/>.</t>

<t>Additional values <bcp14>MAY</bcp14> be used, provided the process of Standards Action with Expert Review described in <xref section="8.2.1" target="RFC5545"/> is used to register them, using the template in <xref section="8.2.6" target="RFC5545"/>.</t>

<t>The initial contents of the "SUBSTATE Values" registry are as follows:</t>

<table>
  <name>Initial Contents of the SUBSTATE Values Registry</name>
  <thead>
    <tr>
      <th align="left">Substate</th>
      <th align="left">Status</th>
      <th align="left">Reference</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left"><t>OK</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-substate"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>ERROR</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-substate"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>SUSPENDED</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-substate"/> of RFC 10051</t></td>
    </tr>
  </tbody>
</table>

</section>

<section><name>TASK-MODE Values Registry</name>

<t>IANA has created a new iCalendar registry called "TASK-MODE Values" for values of the "TASK-MODE" property defined in <xref target="prop-task-mode"/>.</t>

<t>Additional values <bcp14>MAY</bcp14> be used, provided the process of Standards Action with Expert Review described in <xref section="8.2.1" target="RFC5545"/> is used to register them, using the template in <xref section="8.2.6" target="RFC5545"/>.</t>

<t>The initial contents of the "TASK-MODE Values" registry are as follows:</t>

<table>
  <name>Initial Contents of the TASK-MODE Values Registry</name>
  <thead>
    <tr>
      <th align="left">Task Mode</th>
      <th align="left">Status</th>
      <th align="left">Reference</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left"><t>AUTOMATIC-COMPLETION</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-task-mode"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>AUTOMATIC-FAILURE</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-task-mode"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>AUTOMATIC</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-task-mode"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>CLIENT</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-task-mode"/> of RFC 10051</t></td>
    </tr>
    <tr>
      <td align="left"><t>SERVER</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="prop-task-mode"/> of RFC 10051</t></td>
    </tr>
  </tbody>
</table>
</section>

<section><name>Participation Statuses Registry</name>

<t>IANA has added the following new iCalendar participation status to the "Participation Statuses" registry defined in <xref section="8.3.7" target="RFC5545"/> and located here: <eref target="https://www.iana.org/assignments/icalendar" brackets="angle"/>.</t>

<table>
  <name>Participation Statuses Registry</name>
  <thead>
    <tr>
      <th align="left">Participation Status</th>
      <th align="left">Status</th>
      <th align="left">Reference</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left"><t>FAILED</t></td>
      <td align="left"><t>Current</t></td>
      <td align="left"><t><xref target="param-val-partstat"/> of RFC 10051</t></td>
    </tr>
  </tbody>
</table>
</section>
</section>

  </middle>
  <back>
    <references>
      <name>References</name>
    <references>
      <name>Normative References</name>

      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.2119.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4791.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.4918.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5234.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5545.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.5546.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.8174.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9073.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9074.xml"/>
      <xi:include href="https://bib.ietf.org/public/rfc/bibxml/reference.RFC.9253.xml"/>

    </references>
    <references>
      <name>Informative References</name>

      <reference target="https://www.omg.org/spec/BPMN/2.0.2/About-BPMN" anchor="BPMN">
	<front> 
	  <title>Business Process Model and Notation</title>
	  <author>
            <organization>Object Management Group</organization>
          </author>
	  <date month="January" year="2014"/>
	</front> 
	<refcontent>Version 2.0.2</refcontent>
      </reference>

      <reference target="https://www.calconnect.org/docs/architectures/Task%20Architecture%201.0.pdf" anchor="TARCH">
	<front> 
	  <title>Task Architecture V 1.0</title>
          <author>
            <organization>CalConnect</organization>
          </author>
	</front> 
      </reference>

      <reference target="https://docs.oasis-open.org/ws-calendar/ws-calendar-spec/v1.0/cs01/ws-calendar-spec-v1.0-cs01.pdf" anchor="WsCalendar">
	<front> 
	  <title>WS-Calendar Version 1.0</title>
          <author/>
	  <date day="30" month="July" year="2011"/>
	</front> 
	<refcontent>OASIS Committee Specification 01</refcontent>
      </reference>


      <reference target="http://www.workflowpatterns.com/patterns/resource/" anchor="WfRP">
	<front> 
	  <title>Workflow Resource Patterns</title> 
	  <author surname="Russell" initials="N."/>
	  <author surname="ter Hofstede" initials="A.H.M."/>
	  <author surname="Edmond" initials="T."/>
	  <author surname="van der Aalst" initials="W.M.P."/>
	  <date year="2004"/>
	</front> 
	<refcontent>BETA Working Paper Series, WP 127</refcontent>
      </reference>
    </references>
    </references>

    <section anchor="appendix-a"><name>Examples of Task State Lifecycle</name>

<section><name>Simple Case Status Change</name>

<t>The following is an example of status changes when assigning and performing a task with one "Attendee".</t>
<table>
  <name>Example of Status Changes in Assigning and Performing a Task with One "Attendee"</name>
  <thead>
    <tr>
      <th align="left"></th>
      <th align="left">STATUS</th>
      <th align="left">PARTSTAT</th>
      <th align="left">Action</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left">1</td>
      <td align="left">-</td>
      <td align="left">-</td>
      <td align="left">Organizer draft</td>
    </tr>
    <tr>
      <td align="left">2</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">Organizer sends iTIP "REQUEST"</td>
    </tr>
    <tr>
      <td align="left">3</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">ACCEPTED</td>
      <td align="left">Attendee "REPLY"</td>
    </tr>
    <tr>
      <td align="left">4</td>
      <td align="left">PENDING</td>
      <td align="left">ACCEPTED</td>
      <td align="left">Task accepted but waiting on some "trigger" to start (e.g., another task has to finish first)</td>
    </tr>
    <tr>
      <td align="left">5</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">Attendee "REPLY" now working on the task</td>
    </tr>
    <tr>
      <td align="left">6</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">COMPLETED</td>
      <td align="left">Attendee "REPLY" completed</td>
    </tr>
    <tr>
      <td align="left">7</td>
      <td align="left">COMPLETED</td>
      <td align="left">COMPLETED</td>
      <td align="left">Overall state set by either the Organizer for TASK-MODE=CLIENT or the server for AUTOMATIC-COMPLETION</td>
    </tr>
  </tbody>
</table>
</section>

<section><name>Example for Multiple "Attendees"</name>

<t>The following is an example of status changes when assigning and performing a task with two "Attendees" (A1 and A2).</t>

<table>
  <name>Example for Multiple "Attendees"</name>
  <thead>
    <tr>
      <th align="left"></th>
      <th align="left">STATUS</th>
      <th align="left">PARTSTAT (A1)</th>
      <th align="left">PARTSTAT (A2)</th>
      <th align="left">Action</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left">1</td>
      <td align="left">-</td>
      <td align="left">-</td>
      <td align="left">-</td>
      <td align="left">Organizer draft</td>
    </tr>
    <tr>
      <td align="left">2</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">Organizer sends iTIP "REQUEST"</td>
    </tr>
    <tr>
      <td align="left">4</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">ACCEPTED</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">Attendee 1 "REPLY"</td>
    </tr>
    <tr>
      <td align="left">5</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">ACCEPTED</td>
      <td align="left">ACCEPTED</td>
      <td align="left">Attendee 2 "REPLY"</td>
    </tr>
    <tr>
      <td align="left">6</td>
      <td align="left">PENDING</td>
      <td align="left">ACCEPTED</td>
      <td align="left">ACCEPTED</td>
      <td align="left">Task accepted but waiting on some "trigger" to start (e.g., another task has to finish first)</td>
    </tr>
    <tr>
      <td align="left">7</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">ACCEPTED</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">Attendee 2 "REPLY" now working on the task</td>
    </tr>
    <tr>
      <td align="left">8</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">Attendee 1 "REPLY" now working on the task</td>
    </tr>
    <tr>
      <td align="left">9</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">COMPLETED</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">Attendee 1 "REPLY" completed (overall status still IN-PROCESS)</td>
    </tr>
    <tr>
      <td align="left">10</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">COMPLETED</td>
      <td align="left">COMPLETED</td>
      <td align="left">Attendee 2 "REPLY" completed</td>
    </tr>
    <tr>
      <td align="left">11</td>
      <td align="left">COMPLETED</td>
      <td align="left">COMPLETED</td>
      <td align="left">COMPLETED</td>
      <td align="left">Overall state set once both "Attendees" are finished. May be set by either the Organizer for TASK-MODE=CLIENT or the server for AUTOMATIC-COMPLETION</td>
    </tr>
  </tbody>
</table>

<aside><t>NOTE: The logic for determining the status change to the "VTODO" calendar component is determined by the Task Organizer based on the "ATTENDEE" property status and other business logic.</t></aside>


</section>

<section><name>Example of Failure</name>

<t>The following is an example of status changes for a task that fails.</t>

<table>
  <name>Example of Failure</name>
  <thead>
    <tr>
      <th align="left"></th>
      <th align="left">STATUS</th>
      <th align="left">PARTSTAT</th>
      <th align="left">Action</th>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td align="left">1</td>
      <td align="left">-</td>
      <td align="left">-</td>
      <td align="left">Organizer draft</td>
    </tr>
    <tr>
      <td align="left">2</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">Organizer sends iTIP "REQUEST"</td>
    </tr>
    <tr>
      <td align="left">3</td>
      <td align="left">NEEDS-ACTION</td>
      <td align="left">ACCEPTED</td>
      <td align="left">Attendee "REPLY"</td>
    </tr>
    <tr>
      <td align="left">4</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">Attendee "REPLY" now working on the task</td>
    </tr>
    <tr>
      <td align="left">5</td>
      <td align="left">IN-PROCESS</td>
      <td align="left">FAILED</td>
      <td align="left">Attendee "REPLY" task failed</td>
    </tr>
    <tr>
      <td align="left">6</td>
      <td align="left">FAILED</td>
      <td align="left">FAILED</td>
      <td align="left">Overall state set by Organizer for TASK-MODE=CLIENT or by server for AUTOMATIC-FAILURE</td>
    </tr>
  </tbody>
</table>

</section>
</section>

    <section anchor="acknowledgements" numbered="false"><name>Acknowledgements</name>

<t>The authors would like to thank the members of the Calendaring and Scheduling Consortium technical committees and the following individuals for contributing their ideas, support, and comments:
<contact fullname="John Chaffee"/>, <contact fullname="Marten Gajda"/>, and <contact fullname="Ken Murchison"/>.</t>

<t>The authors would also like to thank CalConnect, the Calendaring and Scheduling Consortium, for advice with this specification.</t>
</section>

  </back>
</rfc>
